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Monitoring system usage
The Server Monitor provides information about how your system is performing by displaying what tasks 
the server is currently running, the current load on your hardware, and a summary of what has happened 
since the server was last restarted. To view the Server Monitor, open the Core Services folder on the 
administrator's Desktop. The Server Monitor also provides information about FirstClass services and 
mirrored volumes.

The Session Monitor is a real-time online display showing the names of logged-in users and what they are 
doing. To view the Session Monitor, choose Admin > Session Monitor, or open the Core Services folder on 
the administrator's Desktop. Some tasks you can perform from this window are logging off users, viewing 
users' Desktops, or viewing users' profiles.
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The Session Monitor
The Session Monitor is a real-time online display showing the names and activities of logged-in users. To 
start the Session Monitor, choose Admin > Session Monitor, or double-click Monitors and then Session 
Monitor.

The Session Monitor displays a row for each active session.

Column Description

Connection Protocol - An icon indicates the connection protocol used to connect to 
the FirstClass server.

ID The session ID. 

Connection type - An icon indicates the type of connection. Note that all Internet 
connections have a single icon with characters indicating different protocols. For 
more information, see the Connection type icons table.

Empty/Full - Indicates whether the user is approaching his daily connection limit or 
the inactivity limit. 

Name The user’s full name.

User ID The user’s user ID.

Action The action the user is currently performing. If the field is blank, the user has 
performed no action in the last minute.

Last Object The last object the user used.

Open Objects All objects the user has open.

Connection type icons

Mac Windows

Gateway Voice Services

Internet Services Java (Android or Synchronization Services session)

FirstClass GO FirstClass Web Services

HTTP iOS session

NNTP LDAP
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Finger FTP

SMTP IMAP4
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Disk use statistics
When FirstClass performs an audit, it produces a Disk Usage report. This report records how much hard 
disk space is used by each of your users. A Disk Usage report is named DiskUse.txt.

Note
If audit does not run to completion (it reaches the scheduled end time before auditing all items in the 
network store), a diskuse.tmp file will be created. This file will be appended during the subsequent 
audit(s) until the entire network store has been audited. It will then be named diskuse.txt. 

You can view a disk use statistics file using FirstClass or a text editor, or import it into a spreadsheet (see 
your spreadsheet program documentation for details). 

The report contains a one-line entry for each user, with the following information:

• first column - the user's unique user ID

• second column - the name of the volume on which the user account is registered

• third column - the total space

For performance reasons, FirstClass no longer maintains this field. For backward compatibility with log 
analysis programs, this field remains, but is always zero.

• fourth column - the total number of files

For performance reasons, FirstClass no longer maintains this field. For backward compatibility with log 
analysis programs, this field remains, but is always zero.

• fifth column - the total referenced space

The total size, in kilobytes, of incoming and outgoing messages, documents, and uploaded files in the 
user's Mailbox and folders.

• sixth column - the total referenced files

The total number of incoming and outgoing messages, documents, and uploaded files in the user's 
Mailbox and folders.

• seventh column - the user's privileges

Special privileges granted to the user. This field can contain one or more of the following:

A - administrator (or subadministrator)

E - edit user information

U - view unlisted

V - view user information.

P indicates that the user's account was only partially audited.

Viewing a Disk Usage file using FirstClass
To view a Disk Usage report while you are logged into FirstClass:

1 Open the Reports folder on the administrator's Desktop.

2 Open the the Statistics Folder.

3 Hold down the shift key and double-click DiskUse.txt.

Viewing a Disk Usage file using a text editor
To view a Disk Usage report when you are not logged into FirstClass:
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1 Open the FCNS folder (Windows) or fcns folder (Mac) on your hard drive.

2 Open the Stats.dir folder. 

3 Open the DiskUse.txt file with your text editor.

To view a Disk Usage report when you are logged into FirstClass Server (as admin, using FirstClass Client):

1 Open the Reports > Statistics folder from the Admin desktop.

2 Select DiskUse.txt and choose File > Download.

3 Open the downloaded copy of DiskUse.txt with your text editor.

Top

Releasing disk space
In your System Profile, you can configure the minimum free disk space required on each volume on your 
server. When the amount of free disk space on a volume is less than or equal to this amount, the server 
refuses to accept messages from users or gateways on that volume.

There are several ways you can free up space:

• Use the Disk Usage report to identify users who are using excessive space. Ask these users to clean out 
their Mailboxes.

• Set disk usage quotas on the Group Privileges form (for groups of users), or on a user's User 
Information form (for individual users).

• Look for and delete files with large attachments (remove and delete the attachments before deleting the 
files).

• Make sure all aliases of a deleted item are also deleted. The space an item takes up is recovered only 
when all copies are deleted. Deleting a large file recovers no space unless the alias is also deleted from 
the sender's Mailbox (and from the Mailboxes of all other recipients).

• Decrease the expiry period on the System Profile form or on the Permissions forms of your busiest 
conferences.

• Delete old statistics and log files. We suggest that you back up these files before you delete them, in 
case you need to troubleshoot a recurring problem.

In Mac, the statistics files are located in fcns\stats.dir. The log files are located in fcns\logfiles. 

In Windows, the statistics files are located in FCNS/STATS.DIR. The log files are located in 
FCNS/LOGFILES.

To recover freed disk space, trash collection must be run after files are deleted. You can force a trash 
collection immediately, or wait until the next scheduled trash collection takes place.

Top

User statistics
FirstClass lets you collect selected user activity statistics. By default, each record contains user ID, time, 
and date fields, plus other fields specific for the record type. A user statistics file is named either yymmdd  
or yymmddI where yymmdd is the date the log file was created and 'I' at the end of the date signifies the 
file is for Internet user statistics only. This file is updated daily at midnight. If the server is not running at 
midnight, the new daily file will begin when the server is restarted.  

Creating customized user statistics reports
1 On the administrator's Desktop, open the Reports folder.

2 Double-click the Statistics Control form.

3 Complete the fields.

4 In the Journaling control section, select the actions you want to record in the user statistics file.
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The number of actions you select and the activity level on your FirstClass system determines the size 
of your statistics file.

5 Close the form and save your changes.

Collecting activity statistics on Linux
For FirstClass on Linux, the statistics folder path you set when completing the Statistics Control form must 
be an fcadmin:admin writable directory. The recommended path is

/opt/fcsd/stats.

After creating such a folder, configure this path in the server as follows:

1 Open the Reports folder on the administrator’s Desktop.

2 Double-click the Statistics Control form.

3 Enter the exact path in the Statistics folder path.

Viewing a user statistics file
1 Open the folder you specified in the "Statistics folder path" field on the Statistics Control form.

2 Open any of the files that you wish to view.

The files open in TextEdit (Mac) or Notepad (Windows).

The user statistics file format
A user statistics file consist of fields that are separated by the delimiter you specified on the Statistics 
Control form.

These are the common field types that can be applied to each record:

• the user ID (userID) of the user performing the action

• the date (date) the action was performed, in the format ddmmyy

• the time (time) the action was performed, in the format hh:mm:ss am|pm

• the IP address (IP address) of the computer where the action was performed

• the user's primary organizational unit (OU)

• the unique file ID (fileID) of the file or folder being processed. 

FirstClass uses file IDs to access the files and folders on a volume

• the client ID (clientID)of the user performing the action. 

FirstClass assigns a unique client ID to each user. The client ID is never assigned to another user.

• the message ID (messageID) of the message being processed

Every message in FirstClass has a unique message ID.

• the name of the object (obj name) being processed

• the type of object (obj type) being processed 

• the parent object (parent obj) of the object being processed

An example of this is a conference item's parent object would be the conference.

• the file size (in bytes) (file size) of the object being processed.

• the IP address (if selected) of the client machine where the action was performed.

• the primary organizational unit (OU) (if selected) of the user performing the action.

User activities in the Journaling section
For details about the journaling fields, click here.

Deleting user statistics files
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Delete statistics files regularly to maintain disk space availability. However, we suggest you back up these 
files before deleting them in case you need them later to troubleshoot an ongoing problem. 

Caution
Do not delete a statistics file unless you wish to reset the server statistics counters.

Top

Server statistics
The server statistics file (Stats.txt) is a cumulative summary of all server events that have occurred since 
the server was first installed. This file is updated daily at midnight. If the server is not running at midnight, 
the new daily file will begin when the server is restarted.

You can view a server statistics file using FirstClass or a text editor, or import it into a spreadsheet (see 
spreadsheet program documentation for details).

The server statistics file contains the following information:

• Remote user statistics

Total Logins number of logins

Total Opens number of windows opened

Total Closes number of windows closed

Total Creates number of messages and files created

Total Submits number of messages sent

Total DirSearches number of times the Directory was searched

Total Timeouts number of sessions that ended because the daily time limit was exceeded

Total Failed UIs number of sessions that ended because of link failures

Bytes Uploaded number of bytes transferred to the server (uploaded files and attachments)

Bytes Downloaded number of bytes transferred from the server (downloaded files and 
attachments)

Total Connect total time all users were connected

• Network user statistics

The same statistics types for regular users as described for remote users. 

• CLUI statistics

The same statistics types for terminal, terminal emulation, and Telnet users as described for remote 
users. 

• Server statistics

Server totals:

Total Deliveries number of messages delivered

Recoveries number of server recoveries (from power failures, and so on)

Users Added number of user accounts added

Users Deleted number of user accounts deleted

Rejected Sessions number of times users could not connect because all sessions were in use. 
If this number is high, you might consider purchasing additional sessions.

Auto-registers number of autoregistrations

Write Protects number of times the server entered write-protect mode because of a lack of 
disk space or an excessive number of files. 
If this number is high, consider moving your FirstClass system to a volume 
with a larger storage capacity.
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Resetting server statistics
To reset server statistics counters, delete the Stats.txt file.

Top

Adoption metrics
The server stores information in an XML file that will help you to understand the adoption rate of your 
server.

The information is written to the file adoption.xml located in FCNS > stats.dir. This file is accessible 
through Reports > Statistics Folder on the admin Desktop.

The file is updated daily at midnight as well as at server start up and shut down. If the server is shut 
down, the Date column will be marked with an asterisk.

You can view a server adoption file using a text editor or parse the data using your own XML parser.

"adoption.xml" contains the following information:

Tag Description

<Date> YYYY-MM-DD HH:MM:SS

<IntUsers> Number of regular users

<ExtUsers> Number of remote users

User Activity Based Metrics (Structure 1)

<User_Login> Logged inTab

<User_Status> Changed status messages

<User_Search> Initiated search

<User_SearchPerson> Initiated "Discovery" of people

<User_SearchCommunity> Initiated "Discovery" of communities

<User_Conference> Created a new conference

<User_Community> Created a new community

<User_Subscribe> Joined a new community

<User_ Post> Posted to a community

<User_ Blog> Posted to a blog

<User_ Follow> Started to follow somebody new

<User_ Hit> Hit/read

System Based Metrics (Structure 2)

<System_Login> Logged in

<System_Status> Changed status messages

<System_Search> Initiated search

<System_SearchPerson> Initiated "Discovery" of people

<System_SearchCommunity> Initiated "Discovery" of communities

<System_Conference> Created a new conference

<System_Community> Created a new community

<System_Subscribe> Posted to a community

<System_Post> Posted to a blog

<System_Blog> Started to follow somebody new
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<System_Follow> Started to follow somebody new

<System_Hit> Hit/read

Blog based Metrics (Structure 3)

<Blog_Count> Number of instances (not reset at midnight)

<Blog_Posts> Number of posts

<Blog_Hits> Number of hits/reads

<Blog_Active> Number of instances with a post or hit

<Blog_Subscribers> Number of subscribers (not reset at midnight)

Community Based Metrics (Structure 4)

<Community_Count> Number of instances (not reset at midnight)

<Community_ Posts> Number of posts

<Community_ Hits> Number of hits/reads

<Community_ Active> Number of instances with a post or hit

<Community_ Subscribers> Number of members (not reset at midnight)

Conference Based Metrics (Structure 5)

<Conference_Count> Number of instances (not reset at midnight)

<Conference_ Posts> Number of posts

<Conference_ Hits> Number of hits/reads

<Conference_ Active> Number of instances with a post or hit

<Conference_ Subscribers> Number of members (not reset at midnight)

All other fields are reserved for future use.

Top

Finding inactive users
At some point, you may wish to locate and delete inactive users. The best way to do this is to execute a 
scripting command to retrieve the last logged in date for all of your users. 

The scripting command is

GET USER userid 1201 1202 1204 1230 +d

where userid is replaced with the user ID of the user you are retrieving information about.

If you send this script (one line per user), it will return the userID, first name, last name, and the date and 
time of the last login for the user.

For example, the following message sent to batch admin:

GET USER msmith 1201 1202 1204 1230 +d  

might return something like this:

1201 0 "MSmith" 1202 0 "Mike" 1204 0 "Smith" 1230 14 "2009/11/07" 16:47:55"

To retrieve all of the user IDs on your system, use the FirstClass Scripting LIST command.

Once you have retrieved all user IDs from your server, you can build the batch script within Microsoft Excel. 
An example of a completed Microsoft Excel spreadsheet would look like this.
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To send the commands to the server, copy all of the cells from the spreadsheet and:

1 Log in as the administrator.

2 Start a new message in the administrator Mailbox and address the message to "batch admin" (no 
quotes).

3 Begin the body of the message with the word "Reply" so the server will respond back with confirmation 
or errors after processing the request.

4 Paste the copied cells after the first "Reply" line by using Edit > Paste Plain Text.

5 Send the message.

You will receive a reply from the server that will include the user ID, first name, last name, and last 
logged in date of all the users listed in the script.

Note
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Dates returned as 01/01/04 are an indication that the user has never logged in.
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Daily log files
FirstClass creates a log file of the console activities for each day that the server is active. Log files are 
named yymmdd.txt, where yymmdd signifies the date the log file was created. This file is updated daily at 
midnight. If the server is not running at midnight, the new daily file will begin when the server is restarted. 
 

Viewing log files
To open a log file while logged into FirstClass:

1 Open Reports > Log Files on the administrator's Desktop.

2 Open the log file for the appropriate date.

The report opens in Notepad (Windows) or TextEdit (Mac).

To open a log file while logged off of FirstClass:

1 Open the FCNS folder (Windows) or fcns folder (Mac or Linux).

2 Open the Logfiles folder.

3 Open the log file for the appropriate date.

The report opens in TextEdit (Mac) or Notepad (Windows).

Deleting log files
Delete server log files regularly to maintain disk space availability. We suggest that you back up these files 
before deleting them in case you need them later to troubleshoot an ongoing problem.

Note
If you don't want to write the console logs to file, delete the Logfiles folder from your hard drive. Never 
delete the Logfiles folder from the administrator's Desktop.

Top

Shutting down and restarting the server

Shutdown options
Some tasks will require you to shut down or restart your server. On all platforms, you can do this from the 
administrator's Desktop. In Windows you can also do this from the component consoles by pressing Ctrl-C. 
Close the components in the reverse order you started them.

These are the shutdown and restart options available in the Admin > Control menu:

• Fast Shutdown

Logs off all users immediately and shuts down the server. You can also click Fast Shutdown on the 
Server tab of the Server Control form.

• Polite Shutdown

Sends a broadcast message to all users instructing them to log off as the server will be shut down. Users 
who do not log off will need to be forced off or you will need to do a fast shutdown, as the server will not 
shut down during a polite shutdown if there are still users logged in. You can also click Polite Shutdown 
on the Server tab of the Server Control form.

• Restart

Initiates a Fast Shutdown of your FirstClass server, followed by a restart of your Windows server 
machine. The FirstClass server is not restarted automatically.

Note
When running a FirstClass server on Mac, only the server is shut down; the machine does not restart.
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We recommend that you always warn your users before shutting down your server, so they can save their 
work. You can do this by either initiating a Polite Shutdown or sending a broadcast message informing your 
users when the server will be shut down. You can also check who is currently online.

When to restart your server
The server requires a restart when performing the following tasks:

• rebuilding/rebalancing the Directory

• changing the Directory sort order

• changing the number of concurrent sessions supported by the server

• when changing the size of the notifier table

• when installing new FirstClass software service packs

• when performing a full restore of the FCNS (Windows) or fcns (Mac, Linux)

• after a very large number of folder creates (i.e. adding 5000 new users). With faster processors and 
more robust systems this shouldn't be an issue.

How to restart properly
To restart FirstClass, start the FirstClass components in this order:

• the server

• Internet Services

• Application Services, if applicable.
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Using FirstClass Updates to keep your software up to date
FirstClass Updates is a utility that automatically connects on a daily basis to the FirstClass Updates Server 
(operated by FirstClass Division) and downloads any new software to your FC Update Service container. It 
does this through a server-to-server gateway.

FirstClass Updates reduces the amount of effort to keep your FirstClass software and system up to date 
with the latest features and fixes, and you can manage software updates directly from the Admin desktop.

FirstClass Updates automatically creates a two-way gateway with secured passwords. While you can 
change these if you wish, it is not necessary, since the server automatically generates strong passwords on 
the first connection. FirstClass Updates then makes a daily outbound connection from your server to 
updates.firstclass.com on port 510 using FCP encryption.

Getting notification of updates
If you want to be notified when new items arrive in the FirstClass Update Service container, you can create 
a mail rule for this container that redirects mail to your personal account.

Updating your server
In most cases, you can update your server in just a few seconds with zero downtime. 

To apply changes to store content and licenses:

1 Open the FC Update Service container on the administrator Desktop. 

2 Select the document corresponding to the desired upgrade.

3 Click Apply Update.

4 Confirm that the upgrade was successful.

To apply executables:

1 Open the FC Update Service container on the administrator Desktop. 

2 Open the object and download the executable. 

3 Confirm that the upgrade was successful.
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Changing gateway settings
As a default, the gateway is set up to connect to the FirstClass Updates Server each day between 4:00 AM 
and 5:00 AM local time. As the administrator, you can change this to suit the needs of your organization.

You also have the ability to change the password, although it is not necessary. A password generator 
automatically creates a password at both sites on the next connection if the password field is blank, or 
updates one site if a password is entered at the other site.

Disabling updates
Although we highly recommend using the FirstClass Updates facility, if you wish to stop updates, disable 
the schedule on the Scheduling tab of the gateway. This will still allow you to connect manually or restore 
the schedule in the future.

 Caution
We do not recommend deleting the gateway. Deleting the gateway will make it difficult to re-enable 
the facility in the future. Disable it instead using the method described above.
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Scheduling routine maintenance tasks
FirstClass is designed in such a way that routine system maintenance tasks run on a regular basis behind 
the scenes. But there may be additional tasks that you, as the administrator, want to run on a daily, weekly 
or monthly basis for tracking or reporting purposes.

You can automate the running of these tasks by creating events in the System Events Calendar that is 
located in the Core Services folder on the administrator's Desktop. When a system event runs, the server 
console log will be updated to indicate that the event occurred, and who initiated the event.

Top

Maintaining the search index

About indexed searching
FirstClass builds an index of FCNS content to optimize searching. All indexable content is recorded in a 
table, and each word in the table is associated with a list of all objects in the FCNS that contain that word. 
When someone searches, FC uses the table to find all the objects that contain the search words.

If someone selects "More options" on the Find form in order to customize their search, FirstClass reverts to 
the old, pre-indexing style of search. FirstClass starts at the current container and walks through its 
content looking for the search words. The objects and containers FirstClass searches depend on the options 
the searcher has selected.

Note
To search for all "To" names in messages, "Cc" names in messages, or histories, users must select 
"More options", then select "To/Cc names"/"History records". Indexed search doesn't include "Cc" 
names or histories, and only includes the first name in "To" fields.

In both cases, FirstClass verifies that the searcher is permitted to access the objects it finds. All objects 
that the searcher has access to are returned to them in the list of search results.

Controlling indexing
The Indexing tab of the Server Control form lets you:

• pause and resume indexing

• save indexing data to disk

• flush indexing data to free up memory

• skip saving the forward index when the server is shut down, to speed up shutdown.
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To monitor indexing activity, use the Search tab of the Server Monitor form.

The search index stoplist
An index stoplist is a list of commonly used words (like "and" or "the") which are of no use in searches. 
The stoplist saves time and resources by omitting these words from searches.

The FirstClass server's stoplist is called stoplist.txt. It is located in the FCServer application folder or in the 
indexv2 folder. You can edit this text file to add words you want to the stoplist.

Tip
If you want to omit the most frequently used terms in your organization's documents, you can discover 
them by running the SINDEX scripting command, then add the terms to the stoplist.

At startup time, the server will look for the stoplist first in FCServer, then in indexv2. If this is the first time 
the server has started with indexing turned on, the dictionary is seeded with the contents of the stoplist 
file. Then normal scan and catchup are performed.

When documents are indexed, all words are stored in the DocID files, including the stoplist words. 
However, when a document is inserted in the forward index file, the stoplist words are omitted. This saves 
RAM, disk space, and the time needed to read and write the forward index file.

Keeping spam out of the search index
To prevent garbage from making it into the search index, you can maintain a spam detection file. If any of 
the entries in this file are found in a message, the body of that message won't be indexed.

This file must be named indexingspam and stored in the FCNS or FCServer folder.

Example indexingspam file

#
# Title, Text String, 0 or 1 (strncmp OR strstr)
#
Subject,Mail delivery failed,1
Subject,Undelivered Mail,1
Subject,Undeliverable,1
Subject,Mail Delivery F,1
Subject,failure notice,1
Subject,Delivery failure,1

# This one will not index the message from "FirstClass Server" audit with the subject 
"Audit Summary". The "0" means the subject has to be same length and match perfectly.
Subject,Audit Summary,0

# This one scans the subject for the occurrence of "Undelivered Mail". Then "1" means can 
be anywhere in subject.
# for example: 
1)  "Error: Undelivered Mail returned"
2)  "Failure Notice: Mail Undelivered"
3) "NDN: Undelivered Mail"
4) "NDN: Undelivered mail"

Subject,Undelivered Mail,1
#  this will match 1 and 3.  The contents of those messages will not be indexed.

#
# Title, Text String, nBytes to scan, Offset
#
Body,Hi! This is the ezmlm program.,100,0
Body,Delivery has failed to these, 100, 0
Body,spam message rejected, 1024, 0
Body,This message was created automatically, 100, 0
Body,Below this line is a copy, 1024, 0
Body,Return-Path:, 1024, 0
Body,Content-Type:, 2048, 0
Body,-- Transcript of session follows --, 1024, 0
Body,Hi. This is the qmail-send program, 100, 0
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Body,*** Original Message ***, 1024, 0
Body,**Message you sent was blocked by our bulk email filter**, 1024, 0
Body,This is an automatically generated Delivery Status Notification, 1024, 0
Body,Message could not be delivered., 1024, 0
Body,Unable to deliver message to the following, 512, 0
Body,Content-Transfer-Encoding: base64,2048,0

# Many NDNs returned to a mail system contain garbage. To catch some of these, "Body" 
strings can be used.
# Starting at body offset 0, look in the first 1024 bytes for the message "-- Transcript 
of session follows --"  these generally have images in the body or internet headers
Body,-- Transcript of session follows --, 1024, 0

# Some are easy to detect, this is an NDN (which cannot be detected) but the message 
contains the string "spam message rejected" which is easily found.
Body,spam message rejected, 1024, 0

#
# Title,Text String,  0 or 1 (strncmp OR strstr)
#
From,Internet Mail Service, 0
From,MAILER-DAEMON,1

# Most NDNs come back with "Internet Mail Service" which is not useful in the index.
From,Internet Mail Service, 0

# This one is very useful. 
# When querying the index for the most words/stop lists etc, the contents of the returned 
message, messes up the index.  So this allows index query without polluting the index.

From,Batch Admin,0

Top

Repairing Directory errors
Directory integrity issues can occasionally occur due to user error, power failures, or other unpredictable 
circumstances.

Errors in user data
If a user discovers errors such as missing or damaged data, perform a single audit to diagnose and repair 
the error. This audit will run in protected mode and will not remove any deleted or expired items.

Errors in many Directory entries
If a large group of user accounts are missing or damaged in the Directory, consider running a Directory 
rebuild. If you are unsure of whether or not you need to perform a rebuild, call our customer support or 
your reseller to discuss your issue and to come up with the best course of action for the situation.

Errors in a single Directory entry
If one user's Directory information is corrupted or missing, you can diagnose and repair this user's 
Directory entry without impacting the performance of your server. 

Any of the following circumstances indicate that you may have a Directory issue with a user:

• one or more of the following is missing in the administrator's List Directory:

• Client ID

• User ID

• User's last name

• user cannot log in and receives Error 1035

• other users and the administrator cannot address mail to the user



Seite  15  von  17

• the user appears in the administrator's List Directory, but the administrator cannot open the user's User 
Information form.

Diagnosing and repairing single Directory entries

Step 1 - Diagnose

1 Open the User Directory Diagnostics form located in Admin Help > Administration > Admin Resources.

2 In the Step one section, enter the Client ID, User ID and Last name of the user whose Directory entry 
you want to diagnose.

Note 
All three fields must be entered.

3 Click Diagnose.

4 Send the message.

A reply message will be sent to the administrator's Mailbox. The message will have three sections, 
corresponding the the three identifications entered in the diagnosis. 

If there is no Directory issue with the user, no errors will be found in any entry. The reply message will look 
like the following:

If there is a Directory issue with the user, one or more sections will contain errors. If one or two contain 
errors, but at least one section contains no errors, you can repair the Directory entry.

Step 2 - Repair

1 Unsend the Directory Diagnostics FirstClass scripting message in the administrator's Mailbox.

2 In the Step two section, select the index that had no errors. 

Note
If the Client index and another index were both error free, select the Client Index. 

3 Click Repair.

4 Send the message.

A repair confirmation will be sent to the administrator's Mailbox.

If the Directory entry is not repaired and you experience further issues, contact Customer Support to solve 
the issue.
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Best practices
· Check the monitors often. They provide good indicators of your system behavior.

· Reset monitors on a regular basis.

· Check the monitors each time you do hardware upgrades or Directory rebuilds.

· Delete log files on a regular basis as they become obsolete.

· Disable logging before starting a manual full audit, as sessions on slow servers might experience 
communication link failures and be dropped.

· Back up often. Although FirstClass is a very reliable product, accidents happen and you want to be 
prepared.

· Keep the media containing the backup files apart from your server. In case of flood or fire, this will 
preserve your data integrity.

· Always contact Customer Support before performing a rebuild or restore. Failure to do so can cause 
irreparable damage to your network store.

System maintenance checklist
This checklist will help you keep a watchful eye on your system and establish system benchmarks. By 
going over this list on a regular basis, you’ll be able to differentiate between a temporary spike in usage 
and a sustained usage increase.

What to check Where to check Possible action

Does your system have enough 
capacity to support concurrent 
logins?

Server Monitor, Summary tab, 
Active Sessions field

Upgrade the basic capacity limit 
to an MP or VLS license.

Does your system have enough 
Remote licenses installed to 
support remote user connections?

Server Monitor, Users tab, 
Remote sessions field

Buy more licenses.

How much of your computer's 
capacity is the server using?

Server Monitor, Summary tab, 
Task load % field

Upgrade hardware.

How much disk space is the 
network store using?

Server Monitor, Volumes tab, Disk 
usage % field

Take one or more of the following 
actions:

• move to a larger hard drive

• approve another volume

• reduce the disk usage limit.

If the increase occurs suddenly, 
use the disk use report to 
determine which users have used 
the most space.

Is mirroring still enabled? Server Monitor, Volumes tab, Disk 
mirror status field

Choose Admin > Control > 
Continue Mirroring.

Find the root of problem (for 
example, unreliable network 
connections, FCPUTIL 
configuration).

Do you have enough Internet 
sessions?

Internet Monitor, Total Internet 
sessions LED indicator

Change the number of Internet 
sessions on the Basic Internet 
Setup form. The Internet sessions 
field is located on the Services 
tab.

Do you have enough SMTP Internet Monitor, Outgoing Mail Change the Max. outgoing mail 
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sessions configured? LED indicator field on the Basic Internet Setup 
form - mail tab.
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